// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(s1|s2|s3|s4)|(sA|sB|sC|sD)|(s@|s#|s\$|s%)").unwrap();
let string = "s1 sA s3 s@";
let substitution = "${1:+s5}${2:+sE}${3:+s£}";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}