import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(s1|s2|s3|s4)|(sA|sB|sC|sD)|(s@|s#|s\\$|s%)";
final String string = "s1 sA s3 s@";
final String subst = "${1:+s5}${2:+sE}${3:+s£}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}