use strict;
my $str = 's1 sA s3 s@';
my $regex = qr/(s1|s2|s3|s4)|(sA|sB|sC|sD)|(s@|s#|s\$|s%)/mp;
my $subst = '${1:+s5}${2:+sE}${3:+s£}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";