import Foundation
let pattern = ##"(s1|s2|s3|s4)|(sA|sB|sC|sD)|(s@|s#|s\$|s%)"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"s1 sA s3 s@"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"${1:+s5}${2:+sE}${3:+s£}"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)