const regex = /(s1|s2|s3|s4)|(sA|sB|sC|sD)|(s@|s#|s\$|s%)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(s1|s2|s3|s4)|(sA|sB|sC|sD)|(s@|s#|s\\$|s%)', 'gm')
const str = `s1 sA s3 s@`;
const subst = `${1:+s5}${2:+sE}${3:+s£}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);