$re = '/(s1|s2|s3|s4)|(sA|sB|sC|sD)|(s@|s#|s\$|s%)/m';
$str = 's1 sA s3 s@';
$subst = "${1:+s5}${2:+sE}${3:+s£}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;