package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(s1|s2|s3|s4)|(sA|sB|sC|sD)|(s@|s#|s\$|s%)`)
var str = `s1 sA s3 s@`
var substitution = "${1:+s5}${2:+sE}${3:+s£}"
fmt.Println(re.ReplaceAllString(str, substitution))
}