#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-zA-Z0-9!@#$%^&*()_+\-=\[\]{};':"\\|,.<>\/?\sÀ-ÿĀ-ſƀ-ɏḀ-ỿɐ-ʯ]*$"
Local $sString = "München, Germany" & @CRLF & _
"Göteborg, Sweden" & @CRLF & _
"Québec City, Canada" & @CRLF & _
"São Paulo, Brazil" & @CRLF & _
"Reykjavík, Iceland" & @CRLF & _
"İstanbul, Turkey" & @CRLF & _
"Marseille, France" & @CRLF & _
"Kraków, Poland" & @CRLF & _
"Córdoba, Spain" & @CRLF & _
"Zürich, Switzerland" & @CRLF & _
"Brno, Czech Republic" & @CRLF & _
"Ljubljana, Slovenia" & @CRLF & _
"Český Krumlov, Czech Republic" & @CRLF & _
"Tromsø, Norway" & @CRLF & _
"Görlitz, Germany" & @CRLF & _
"äöüÄÖÜßẞáéíóúàèìòùâêîôûÁÉÍÓÚÀÈÌÒÙÂÊÎÔÛãõñÑçÇ" & @CRLF & _
"ČčŠšŽžĎŇňŘřěĚŸİ磳ƵƷąćęłńśźżĄĆĘŁŃŚŹŻẞ" & @CRLF & _
"مرحبا بوينوس دياس" & @CRLF & _
"Brčko, Bosnia and Herzegovina" & @CRLF & _
"Görlitz, Germany" & @CRLF & _
"Québec City, Canada" & @CRLF & _
"Łódź, Poland" & @CRLF & _
"Reykjavík, Iceland" & @CRLF & _
"Gdańsk, Poland" & @CRLF & _
"Malmö, Sweden" & @CRLF & _
"České Budějovice, Czech Republic" & @CRLF & _
"Žilina, Slovakia" & @CRLF & _
"Barcelona, Spain" & @CRLF & _
"Göteborg, Sweden" & @CRLF & _
"Málaga, Spain" & @CRLF & _
"Bratislava, Slovakia" & @CRLF & _
"Kraków, Poland" & @CRLF & _
"Bordeaux, France" & @CRLF & _
"Köln (Cologne), Germany" & @CRLF & _
"Reykjavík, Iceland" & @CRLF & _
"Helsinki, Finland" & @CRLF & _
"Praha (Prague), Czech Republic" & @CRLF & _
"Lisboa (Lisbon), Portugal"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")