import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-zA-Z0-9!@#$%^&*()_+\\-=\\[\\]\\{\\};':\"\\\\|,.<>\\/?\\sÀ-ÿĀ-ſƀ-ɏḀ-ỿɐ-ʯ]*$";
final String string = "München, Germany\n"
+ "Göteborg, Sweden\n"
+ "Québec City, Canada\n"
+ "São Paulo, Brazil\n"
+ "Reykjavík, Iceland\n"
+ "İstanbul, Turkey\n"
+ "Marseille, France\n"
+ "Kraków, Poland\n"
+ "Córdoba, Spain\n"
+ "Zürich, Switzerland\n"
+ "Brno, Czech Republic\n"
+ "Ljubljana, Slovenia\n"
+ "Český Krumlov, Czech Republic\n"
+ "Tromsø, Norway\n"
+ "Görlitz, Germany\n"
+ "äöüÄÖÜßẞáéíóúàèìòùâêîôûÁÉÍÓÚÀÈÌÒÙÂÊÎÔÛãõñÑçÇ\n"
+ "ČčŠšŽžĎŇňŘřěĚŸİ磳ƵƷąćęłńśźżĄĆĘŁŃŚŹŻẞ\n"
+ "مرحبا بوينوس دياس\n"
+ "Brčko, Bosnia and Herzegovina\n"
+ "Görlitz, Germany\n"
+ "Québec City, Canada\n"
+ "Łódź, Poland\n"
+ "Reykjavík, Iceland\n"
+ "Gdańsk, Poland\n"
+ "Malmö, Sweden\n"
+ "České Budějovice, Czech Republic\n"
+ "Žilina, Slovakia\n"
+ "Barcelona, Spain\n"
+ "Göteborg, Sweden\n"
+ "Málaga, Spain\n"
+ "Bratislava, Slovakia\n"
+ "Kraków, Poland\n"
+ "Bordeaux, France\n"
+ "Köln (Cologne), Germany\n"
+ "Reykjavík, Iceland\n"
+ "Helsinki, Finland\n"
+ "Praha (Prague), Czech Republic\n"
+ "Lisboa (Lisbon), Portugal";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}