use strict;
my $str = 'München, Germany
Göteborg, Sweden
Québec City, Canada
São Paulo, Brazil
Reykjavík, Iceland
İstanbul, Turkey
Marseille, France
Kraków, Poland
Córdoba, Spain
Zürich, Switzerland
Brno, Czech Republic
Ljubljana, Slovenia
Český Krumlov, Czech Republic
Tromsø, Norway
Görlitz, Germany
äöüÄÖÜßẞáéíóúàèìòùâêîôûÁÉÍÓÚÀÈÌÒÙÂÊÎÔÛãõñÑçÇ
ČčŠšŽžĎŇňŘřěĚŸİ磳ƵƷąćęłńśźżĄĆĘŁŃŚŹŻẞ
مرحبا بوينوس دياس
Brčko, Bosnia and Herzegovina
Görlitz, Germany
Québec City, Canada
Łódź, Poland
Reykjavík, Iceland
Gdańsk, Poland
Malmö, Sweden
České Budějovice, Czech Republic
Žilina, Slovakia
Barcelona, Spain
Göteborg, Sweden
Málaga, Spain
Bratislava, Slovakia
Kraków, Poland
Bordeaux, France
Köln (Cologne), Germany
Reykjavík, Iceland
Helsinki, Finland
Praha (Prague), Czech Republic
Lisboa (Lisbon), Portugal';
my $regex = qr/^[a-zA-Z0-9!@#$%^&*()_+\-=\[\]{};':"\\|,.<>\/?\sÀ-ÿĀ-ſƀ-ɏḀ-ỿɐ-ʯ]*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}