using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-zA-Z0-9!@#$%^&*()_+\-=\[\]{};':""\\|,.<>\/?\sÀ-ÿĀ-ſƀ-ɏḀ-ỿɐ-ʯ]*$";
string input = @"München, Germany
Göteborg, Sweden
Québec City, Canada
São Paulo, Brazil
Reykjavík, Iceland
İstanbul, Turkey
Marseille, France
Kraków, Poland
Córdoba, Spain
Zürich, Switzerland
Brno, Czech Republic
Ljubljana, Slovenia
Český Krumlov, Czech Republic
Tromsø, Norway
Görlitz, Germany
äöüÄÖÜßẞáéíóúàèìòùâêîôûÁÉÍÓÚÀÈÌÒÙÂÊÎÔÛãõñÑçÇ
ČčŠšŽžĎŇňŘřěĚŸİ磳ƵƷąćęłńśźżĄĆĘŁŃŚŹŻẞ
مرحبا بوينوس دياس
Brčko, Bosnia and Herzegovina
Görlitz, Germany
Québec City, Canada
Łódź, Poland
Reykjavík, Iceland
Gdańsk, Poland
Malmö, Sweden
České Budějovice, Czech Republic
Žilina, Slovakia
Barcelona, Spain
Göteborg, Sweden
Málaga, Spain
Bratislava, Slovakia
Kraków, Poland
Bordeaux, France
Köln (Cologne), Germany
Reykjavík, Iceland
Helsinki, Finland
Praha (Prague), Czech Republic
Lisboa (Lisbon), Portugal";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}