import Foundation
let pattern = ##"^[a-zA-Z0-9!@#$%^&*()_+\-=\[\]{};':"\\|,.<>\/?\sÀ-ÿĀ-ſƀ-ɏḀ-ỿɐ-ʯ]*$"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
München, Germany
Göteborg, Sweden
Québec City, Canada
São Paulo, Brazil
Reykjavík, Iceland
İstanbul, Turkey
Marseille, France
Kraków, Poland
Córdoba, Spain
Zürich, Switzerland
Brno, Czech Republic
Ljubljana, Slovenia
Český Krumlov, Czech Republic
Tromsø, Norway
Görlitz, Germany
äöüÄÖÜßẞáéíóúàèìòùâêîôûÁÉÍÓÚÀÈÌÒÙÂÊÎÔÛãõñÑçÇ
ČčŠšŽžĎŇňŘřěĚŸİ磳ƵƷąćęłńśźżĄĆĘŁŃŚŹŻẞ
مرحبا بوينوس دياس
Brčko, Bosnia and Herzegovina
Görlitz, Germany
Québec City, Canada
Łódź, Poland
Reykjavík, Iceland
Gdańsk, Poland
Malmö, Sweden
České Budějovice, Czech Republic
Žilina, Slovakia
Barcelona, Spain
Göteborg, Sweden
Málaga, Spain
Bratislava, Slovakia
Kraków, Poland
Bordeaux, France
Köln (Cologne), Germany
Reykjavík, Iceland
Helsinki, Finland
Praha (Prague), Czech Republic
Lisboa (Lisbon), Portugal
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)