# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[a-zA-Z0-9!@#$%^&*()_+\-=\[\]{};':\"\\|,.<>\/?\sÀ-ÿĀ-ſƀ-ɏḀ-ỿɐ-ʯ]*$"
test_str = ("München, Germany\n"
"Göteborg, Sweden\n"
"Québec City, Canada\n"
"São Paulo, Brazil\n"
"Reykjavík, Iceland\n"
"İstanbul, Turkey\n"
"Marseille, France\n"
"Kraków, Poland\n"
"Córdoba, Spain\n"
"Zürich, Switzerland\n"
"Brno, Czech Republic\n"
"Ljubljana, Slovenia\n"
"Český Krumlov, Czech Republic\n"
"Tromsø, Norway\n"
"Görlitz, Germany\n"
"äöüÄÖÜßẞáéíóúàèìòùâêîôûÁÉÍÓÚÀÈÌÒÙÂÊÎÔÛãõñÑçÇ\n"
"ČčŠšŽžĎŇňŘřěĚŸİ磳ƵƷąćęłńśźżĄĆĘŁŃŚŹŻẞ\n"
"مرحبا بوينوس دياس\n"
"Brčko, Bosnia and Herzegovina\n"
"Görlitz, Germany\n"
"Québec City, Canada\n"
"Łódź, Poland\n"
"Reykjavík, Iceland\n"
"Gdańsk, Poland\n"
"Malmö, Sweden\n"
"České Budějovice, Czech Republic\n"
"Žilina, Slovakia\n"
"Barcelona, Spain\n"
"Göteborg, Sweden\n"
"Málaga, Spain\n"
"Bratislava, Slovakia\n"
"Kraków, Poland\n"
"Bordeaux, France\n"
"Köln (Cologne), Germany\n"
"Reykjavík, Iceland\n"
"Helsinki, Finland\n"
"Praha (Prague), Czech Republic\n"
"Lisboa (Lisbon), Portugal")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.