#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<a href=?[?:^"](.*?)([^"]+)*."
Local $sString = "Array" & @CRLF & _
"(" & @CRLF & _
" [0] => <div class="genel">" & @CRLF & _
"<div>" & @CRLF & _
"<ul class="table-of-contents">" & @CRLF & _
"<li data-part-id="12">" & @CRLF & _
"<a href="/sayfa2" class="on-navigate-part">" & @CRLF & _
"sayfa1" & @CRLF & _
"</a>" & @CRLF & _
"</li>" & @CRLF & _
"<li data-part-id="23">" & @CRLF & _
"<a href="/BarisYILMAZ" class="on-navigate-part">" & @CRLF & _
"sayfa2" & @CRLF & _
"</a>" & @CRLF & _
"</li>" & @CRLF & _
"<li data-part-id="34">" & @CRLF & _
"<a href="/sayfaZ^''^'^'^'^'^'^'^'^'^+^%%&'^+%^/^&%/%&/%&/" class="on-navigate-part">" & @CRLF & _
"sayfa3" & @CRLF & _
" </a>" & @CRLF & _
"</li>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")