import re
regex = re.compile(r"<a href=?[?:^\"](.*?)([^\"]+)*.", flags=re.MULTILINE)
test_str = ("Array\n"
"(\n"
" [0] => <div class=\"genel\">\n"
"<div>\n"
"<ul class=\"table-of-contents\">\n"
"<li data-part-id=\"12\">\n"
"<a href=\"/sayfa2\" class=\"on-navigate-part\">\n"
"sayfa1\n"
"</a>\n"
"</li>\n"
"<li data-part-id=\"23\">\n"
"<a href=\"/BarisYILMAZ\" class=\"on-navigate-part\">\n"
"sayfa2\n"
"</a>\n"
"</li>\n"
"<li data-part-id=\"34\">\n"
"<a href=\"/sayfaZ^''^'^'^'^'^'^'^'^'^+^%%&'^+%^/^&%/%&/%&/\" class=\"on-navigate-part\">\n"
"sayfa3\n"
" </a>\n"
"</li>\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")