// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<a href=?[?:^"](.*?)([^"]+)*."#).unwrap();
let string = "Array
(
[0] => <div class=\"genel\">
<div>
<ul class=\"table-of-contents\">
<li data-part-id=\"12\">
<a href=\"/sayfa2\" class=\"on-navigate-part\">
sayfa1
</a>
</li>
<li data-part-id=\"23\">
<a href=\"/BarisYILMAZ\" class=\"on-navigate-part\">
sayfa2
</a>
</li>
<li data-part-id=\"34\">
<a href=\"/sayfaZ^''^'^'^'^'^'^'^'^'^+^%%&'^+%^/^&%/%&/%&/\" class=\"on-navigate-part\">
sayfa3
</a>
</li>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}