$re = '/<a href=?[?:^"](.*?)([^"]+)*./m';
$str = 'Array
(
[0] => <div class="genel">
<div>
<ul class="table-of-contents">
<li data-part-id="12">
<a href="/sayfa2" class="on-navigate-part">
sayfa1
</a>
</li>
<li data-part-id="23">
<a href="/BarisYILMAZ" class="on-navigate-part">
sayfa2
</a>
</li>
<li data-part-id="34">
<a href="/sayfaZ^\'\'^\'^\'^\'^\'^\'^\'^\'^\'^+^%%&\'^+%^/^&%/%&/%&/" class="on-navigate-part">
sayfa3
</a>
</li>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);