import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a href=?[?:^\"](.*?)([^\"]+)*.";
final String string = "Array\n"
+ "(\n"
+ " [0] => <div class=\"genel\">\n"
+ "<div>\n"
+ "<ul class=\"table-of-contents\">\n"
+ "<li data-part-id=\"12\">\n"
+ "<a href=\"/sayfa2\" class=\"on-navigate-part\">\n"
+ "sayfa1\n"
+ "</a>\n"
+ "</li>\n"
+ "<li data-part-id=\"23\">\n"
+ "<a href=\"/BarisYILMAZ\" class=\"on-navigate-part\">\n"
+ "sayfa2\n"
+ "</a>\n"
+ "</li>\n"
+ "<li data-part-id=\"34\">\n"
+ "<a href=\"/sayfaZ^''^'^'^'^'^'^'^'^'^+^%%&'^+%^/^&%/%&/%&/\" class=\"on-navigate-part\">\n"
+ "sayfa3\n"
+ " </a>\n"
+ "</li>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}