use strict;
my $str = 'Array
(
[0] => <div class="genel">
<div>
<ul class="table-of-contents">
<li data-part-id="12">
<a href="/sayfa2" class="on-navigate-part">
sayfa1
</a>
</li>
<li data-part-id="23">
<a href="/BarisYILMAZ" class="on-navigate-part">
sayfa2
</a>
</li>
<li data-part-id="34">
<a href="/sayfaZ^\'\'^\'^\'^\'^\'^\'^\'^\'^\'^+^%%&\'^+%^/^&%/%&/%&/" class="on-navigate-part">
sayfa3
</a>
</li>
';
my $regex = qr/<a href=?[?:^"](.*?)([^"]+)*./mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}