import Foundation
let pattern = #"<a href=?[?:^"](.*?)([^"]+)*."#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Array
(
[0] => <div class="genel">
<div>
<ul class="table-of-contents">
<li data-part-id="12">
<a href="/sayfa2" class="on-navigate-part">
sayfa1
</a>
</li>
<li data-part-id="23">
<a href="/BarisYILMAZ" class="on-navigate-part">
sayfa2
</a>
</li>
<li data-part-id="34">
<a href="/sayfaZ^''^'^'^'^'^'^'^'^'^+^%%&'^+%^/^&%/%&/%&/" class="on-navigate-part">
sayfa3
</a>
</li>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)