#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(giới thiệu|hiểu).*(công nghệ).*(ngôn ngữ tự nhiên)"
Local $sString = "giới thiệu cho tôi về công nghệ xử lý ngôn ngữ tự nhiên?" & @CRLF & _
"bạn có thể giới thiệu cho tôi về cách xử lý ngôn ngữ tự nhiên được không." & @CRLF & _
"bạn có thể giới thiệu giú tôi về công nghệ xử lý ngôn ngữ tự nhiên được không." & @CRLF & _
"bạn có thể giúp tôi hiểu về công nghệ ngôn ngữ tự nhiên được không." & @CRLF & _
"công nghệ xử lý ngôn ngữ tự nhiên được như thế nào bạn nhỉ." & @CRLF & _
"bạn có thể giúp tôi hiểu về ngôn ngữ tự nhiên được không." & @CRLF & _
"tôi có thể hiểu về công nghệ ngôn ngữ tự nhiên thế nào bạn nhỉ?" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")