$re = '`(giới thiệu|hiểu).*(công nghệ).*(ngôn ngữ tự nhiên)`';
$str = 'giới thiệu cho tôi về công nghệ xử lý ngôn ngữ tự nhiên?
bạn có thể giới thiệu cho tôi về cách xử lý ngôn ngữ tự nhiên được không.
bạn có thể giới thiệu giú tôi về công nghệ xử lý ngôn ngữ tự nhiên được không.
bạn có thể giúp tôi hiểu về công nghệ ngôn ngữ tự nhiên được không.
công nghệ xử lý ngôn ngữ tự nhiên được như thế nào bạn nhỉ.
bạn có thể giúp tôi hiểu về ngôn ngữ tự nhiên được không.
tôi có thể hiểu về công nghệ ngôn ngữ tự nhiên thế nào bạn nhỉ?
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);