# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(giới thiệu|hiểu).*(công nghệ).*(ngôn ngữ tự nhiên)"
test_str = ("giới thiệu cho tôi về công nghệ xử lý ngôn ngữ tự nhiên?\n"
"bạn có thể giới thiệu cho tôi về cách xử lý ngôn ngữ tự nhiên được không.\n"
"bạn có thể giới thiệu giú tôi về công nghệ xử lý ngôn ngữ tự nhiên được không.\n"
"bạn có thể giúp tôi hiểu về công nghệ ngôn ngữ tự nhiên được không.\n"
"công nghệ xử lý ngôn ngữ tự nhiên được như thế nào bạn nhỉ.\n"
"bạn có thể giúp tôi hiểu về ngôn ngữ tự nhiên được không.\n"
"tôi có thể hiểu về công nghệ ngôn ngữ tự nhiên thế nào bạn nhỉ?\n\n\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.