import Foundation
let pattern = #"(giới thiệu|hiểu).*(công nghệ).*(ngôn ngữ tự nhiên)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
giới thiệu cho tôi về công nghệ xử lý ngôn ngữ tự nhiên?
bạn có thể giới thiệu cho tôi về cách xử lý ngôn ngữ tự nhiên được không.
bạn có thể giới thiệu giú tôi về công nghệ xử lý ngôn ngữ tự nhiên được không.
bạn có thể giúp tôi hiểu về công nghệ ngôn ngữ tự nhiên được không.
công nghệ xử lý ngôn ngữ tự nhiên được như thế nào bạn nhỉ.
bạn có thể giúp tôi hiểu về ngôn ngữ tự nhiên được không.
tôi có thể hiểu về công nghệ ngôn ngữ tự nhiên thế nào bạn nhỉ?
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)