using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(giới thiệu|hiểu).*(công nghệ).*(ngôn ngữ tự nhiên)";
string input = @"giới thiệu cho tôi về công nghệ xử lý ngôn ngữ tự nhiên?
bạn có thể giới thiệu cho tôi về cách xử lý ngôn ngữ tự nhiên được không.
bạn có thể giới thiệu giú tôi về công nghệ xử lý ngôn ngữ tự nhiên được không.
bạn có thể giúp tôi hiểu về công nghệ ngôn ngữ tự nhiên được không.
công nghệ xử lý ngôn ngữ tự nhiên được như thế nào bạn nhỉ.
bạn có thể giúp tôi hiểu về ngôn ngữ tự nhiên được không.
tôi có thể hiểu về công nghệ ngôn ngữ tự nhiên thế nào bạn nhỉ?
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}