// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(giới thiệu|hiểu).*(công nghệ).*(ngôn ngữ tự nhiên)").unwrap();
let string = "giới thiệu cho tôi về công nghệ xử lý ngôn ngữ tự nhiên?
bạn có thể giới thiệu cho tôi về cách xử lý ngôn ngữ tự nhiên được không.
bạn có thể giới thiệu giú tôi về công nghệ xử lý ngôn ngữ tự nhiên được không.
bạn có thể giúp tôi hiểu về công nghệ ngôn ngữ tự nhiên được không.
công nghệ xử lý ngôn ngữ tự nhiên được như thế nào bạn nhỉ.
bạn có thể giúp tôi hiểu về ngôn ngữ tự nhiên được không.
tôi có thể hiểu về công nghệ ngôn ngữ tự nhiên thế nào bạn nhỉ?
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}