import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(giới thiệu|hiểu).*(công nghệ).*(ngôn ngữ tự nhiên)";
final String string = "giới thiệu cho tôi về công nghệ xử lý ngôn ngữ tự nhiên?\n"
+ "bạn có thể giới thiệu cho tôi về cách xử lý ngôn ngữ tự nhiên được không.\n"
+ "bạn có thể giới thiệu giú tôi về công nghệ xử lý ngôn ngữ tự nhiên được không.\n"
+ "bạn có thể giúp tôi hiểu về công nghệ ngôn ngữ tự nhiên được không.\n"
+ "công nghệ xử lý ngôn ngữ tự nhiên được như thế nào bạn nhỉ.\n"
+ "bạn có thể giúp tôi hiểu về ngôn ngữ tự nhiên được không.\n"
+ "tôi có thể hiểu về công nghệ ngôn ngữ tự nhiên thế nào bạn nhỉ?\n\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}