# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<%([-=]):\s*([^|]*?)\s*\|\s*(\w+)(?::([^%]+?))?\s*%>/<%\1 filters.\3(\2, \4) %>/gm;t' <<< "<%=: price | moneyFormat:currency %>
<%=: price | moneyFormat:currency, option2 %>
# Why we need the second regex:
<%=: price | moneyFormat %>
"