use strict;
my $str = '<%=: price | moneyFormat:currency %>
<%=: price | moneyFormat:currency, option2 %>
# Why we need the second regex:
<%=: price | moneyFormat %>
';
my $regex = qr/<%([-=]):\s*([^|]*?)\s*\|\s*(\w+)(?::([^%]+?))?\s*%>/mp;
my $subst = '<%\\1 filters.\\3(\\2, \\4) %>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";