import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<%([-=]):\\s*([^|]*?)\\s*\\|\\s*(\\w+)(?::([^%]+?))?\\s*%>";
final String string = "<%=: price | moneyFormat:currency %>\n"
+ "<%=: price | moneyFormat:currency, option2 %>\n\n"
+ "# Why we need the second regex:\n"
+ "<%=: price | moneyFormat %>\n";
final String subst = "<%\\1 filters.\\3(\\2, \\4) %>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}