// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)<%([-=]):\s*([^|]*?)\s*\|\s*(\w+)(?::([^%]+?))?\s*%>").unwrap();
let string = "<%=: price | moneyFormat:currency %>
<%=: price | moneyFormat:currency, option2 %>
# Why we need the second regex:
<%=: price | moneyFormat %>
";
let substitution = "<%\\1 filters.\\3(\\2, \\4) %>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}