#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)<%([-=]):\s*([^|]*?)\s*\|\s*(\w+)(?::([^%]+?))?\s*%>"
Local $sString = "<%=: price | moneyFormat:currency %>" & @CRLF & _
"<%=: price | moneyFormat:currency, option2 %>" & @CRLF & _
"" & @CRLF & _
"# Why we need the second regex:" & @CRLF & _
"<%=: price | moneyFormat %>" & @CRLF & _
""
Local $sSubst = "<%\1 filters.\3(\2, \4) %>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)