re = /<%([-=]):\s*([^|]*?)\s*\|\s*(\w+)(?::([^%]+?))?\s*%>/m
str = '<%=: price | moneyFormat:currency %>
<%=: price | moneyFormat:currency, option2 %>
# Why we need the second regex:
<%=: price | moneyFormat %>
'
subst = '<%\\1 filters.\\3(\\2, \\4) %>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result