const regex = /<%([-=]):\s*([^|]*?)\s*\|\s*(\w+)(?::([^%]+?))?\s*%>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<%([-=]):\\s*([^|]*?)\\s*\\|\\s*(\\w+)(?::([^%]+?))?\\s*%>', 'gm')
const str = `<%=: price | moneyFormat:currency %>
<%=: price | moneyFormat:currency, option2 %>
# Why we need the second regex:
<%=: price | moneyFormat %>
`;
const subst = `<%\1 filters.\3(\2, \4) %>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);