#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^(([0]?[1-9])|([1-2][0-9])|(3[0-1]))\/(([0]?[1-9])|(1[0-2]))\/(\d{4}))$"
Local $sString = "07/24/1969" & @CRLF & _
"01.01.1900" & @CRLF & _
"10/10/2017" & @CRLF & _
"1830/10/4" & @CRLF & _
"2/10/00" & @CRLF & _
"05-05-92" & @CRLF & _
"18/05/1804" & @CRLF & _
"6/30/1996" & @CRLF & _
"99/00/2000" & @CRLF & _
"06/12/1865" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")