// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^(([0]?[1-9])|([1-2][0-9])|(3[0-1]))\/(([0]?[1-9])|(1[0-2]))\/(\d{4}))$").unwrap();
let string = "07/24/1969
01.01.1900
10/10/2017
1830/10/4
2/10/00
05-05-92
18/05/1804
6/30/1996
99/00/2000
06/12/1865
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}