package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^(([0]?[1-9])|([1-2][0-9])|(3[0-1]))\/(([0]?[1-9])|(1[0-2]))\/(\d{4}))$`)
var str = `07/24/1969
01.01.1900
10/10/2017
1830/10/4
2/10/00
05-05-92
18/05/1804
6/30/1996
99/00/2000
06/12/1865
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}