import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^(([0]?[1-9])|([1-2][0-9])|(3[0-1]))\\/(([0]?[1-9])|(1[0-2]))\\/(\\d{4}))$";
final String string = "07/24/1969\n"
+ "01.01.1900\n"
+ "10/10/2017\n"
+ "1830/10/4\n"
+ "2/10/00\n"
+ "05-05-92\n"
+ "18/05/1804\n"
+ "6/30/1996\n"
+ "99/00/2000\n"
+ "06/12/1865\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}