using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^(([0]?[1-9])|([1-2][0-9])|(3[0-1]))\/(([0]?[1-9])|(1[0-2]))\/(\d{4}))$";
string input = @"07/24/1969
01.01.1900
10/10/2017
1830/10/4
2/10/00
05-05-92
18/05/1804
6/30/1996
99/00/2000
06/12/1865
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}