const regex = /(^(([0]?[1-9])|([1-2][0-9])|(3[0-1]))\/(([0]?[1-9])|(1[0-2]))\/(\d{4}))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^(([0]?[1-9])|([1-2][0-9])|(3[0-1]))\\\/(([0]?[1-9])|(1[0-2]))\\\/(\\d{4}))$', 'gm')
const str = `07/24/1969
01.01.1900
10/10/2017
1830/10/4
2/10/00
05-05-92
18/05/1804
6/30/1996
99/00/2000
06/12/1865
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}