use strict;
my $str = '07/24/1969
01.01.1900
10/10/2017
1830/10/4
2/10/00
05-05-92
18/05/1804
6/30/1996
99/00/2000
06/12/1865
';
my $regex = qr/(^(([0]?[1-9])|([1-2][0-9])|(3[0-1]))\/(([0]?[1-9])|(1[0-2]))\/(\d{4}))$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}