#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)duration\" content=\"PT(?<minutes>\d+)M(?<seconds>\d+)S"
Local $sString = "<meta itemprop="duration" content="PT103M0S">" & @CRLF & _
" <meta itemprop="duration" content="PT0M58S">" & @CRLF & _
"<meta itemprop="videoId" content="3elGSZSWTbM"><meta itemprop="duration" content="PT18M51S""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")