re = /duration\" content=\"PT(?<minutes>\d+)M(?<seconds>\d+)S/m
str = '<meta itemprop="duration" content="PT103M0S">
<meta itemprop="duration" content="PT0M58S">
<meta itemprop="videoId" content="3elGSZSWTbM"><meta itemprop="duration" content="PT18M51S"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end