$re = '/duration\" content=\"PT(?<minutes>\d+)M(?<seconds>\d+)S/m';
$str = '<meta itemprop="duration" content="PT103M0S">
<meta itemprop="duration" content="PT0M58S">
<meta itemprop="videoId" content="3elGSZSWTbM"><meta itemprop="duration" content="PT18M51S"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);