package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)duration\" content=\"PT(?<minutes>\d+)M(?<seconds>\d+)S`)
var str = `<meta itemprop="duration" content="PT103M0S">
<meta itemprop="duration" content="PT0M58S">
<meta itemprop="videoId" content="3elGSZSWTbM"><meta itemprop="duration" content="PT18M51S"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}