import re
regex = re.compile(r"duration\" content=\"PT(?<minutes>\d+)M(?<seconds>\d+)S", flags=re.MULTILINE)
test_str = ("<meta itemprop=\"duration\" content=\"PT103M0S\">\n"
" <meta itemprop=\"duration\" content=\"PT0M58S\">\n"
"<meta itemprop=\"videoId\" content=\"3elGSZSWTbM\"><meta itemprop=\"duration\" content=\"PT18M51S\"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")