const regex = /duration\" content=\"PT(?<minutes>\d+)M(?<seconds>\d+)S/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('duration\\" content=\\"PT(?<minutes>\\d+)M(?<seconds>\\d+)S', 'gm')
const str = `<meta itemprop="duration" content="PT103M0S">
<meta itemprop="duration" content="PT0M58S">
<meta itemprop="videoId" content="3elGSZSWTbM"><meta itemprop="duration" content="PT18M51S"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}