# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\/pictures\/(([a-z0-9]{2,2})([a-z0-9]{2,2})[a-z0-9]{28}\.\w+)/\/p\/$2\/$3\/$1/gmi;t' <<< "/pictures/202cb962ac59075b964b07152d234b70.jpg"