use strict;
my $str = '/pictures/202cb962ac59075b964b07152d234b70.jpg';
my $regex = qr~^/pictures/(([a-z0-9]{2,2})([a-z0-9]{2,2})[a-z0-9]{28}\.\w+)~mip;
my $subst = '/p/$2/$3/$1';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";