import Foundation
let pattern = #"^/pictures/(([a-z0-9]{2,2})([a-z0-9]{2,2})[a-z0-9]{28}\.\w+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"/pictures/202cb962ac59075b964b07152d234b70.jpg"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"/p/$2/$3/$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)